Getting started

The HiFive binary requires Python 2.7. However, the library can be used by Python 2.6 and 2.7. To check your version, run:

> python -V

Installing HiFive

The easiest way to get HiFive is using pip:

> pip install hifive

HiFive can also be obtained from HiFive using the following command:

> git clone

or alternatively, download a snapshot of the repository using the following commands:

> wget
> tar -xf hifive_v1.0.tar

HiFive depends on a few packages and has several others that extend its functionality.

Required Packages

Installing Documentation

In order to build HiFive’s documentation locally, you need to execute the following command:

> cd doc
> make html

This will create the documentation suitable for viewing with a web browser. In order to create a pdf version of the documentation, simply run the following:

> cd doc
> make latexpdf